注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

Q超越兔子的蜗牛O--逸云沙鸥Linux

飘飘何所似,天地一沙鸥;落霞与孤鹜齐飞,秋水共长天一色~~

 
 
 

日志

 
 

【转】cpan安装Perl模块时自动安装依赖模块(自动确认yes)  

2012-05-28 13:21:47|  分类: Perl编程技巧 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

参考资料:http://blog.csdn.net/cdzwm/article/details/5800900

Comprehensive Perl Archive Network是Perl资源的宝库。Perl模块资源的管理工具cpan, 则是安装Perl包时的必不可以的强大工具。但很多Perl模块常常需要依赖很多其它模块才能正常运行。cpan程序的默认设置是需要手工确认这些依赖模块的安装,因此安装起来十分繁琐,费时。经过查找相关的资料,找到了cpan自动安装依赖模块的配置选项。进行如下设置,就可以使cpan程序不需要人工干预就能自动安装依赖模块了。

 

方法一

 在命令行执行如下命令:

cpan
o conf prerequisites_policy follow
o conf commit

exit

方法二

设置如下的环境变量
PERL_MM_USE_DEFAULT=1

使用上面的方法中的一种后,就可以使用cpan安装Perl模块,而不需要人工干预依赖模块的安装了。十分方便快捷。

测试结果:第一种比较靠谱,后面一个貌似没反应。

  评论这张
 
阅读(848)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017